ssossossosso

Forums

Covering OroCommerce topics, B2B eCommerce trends, community updates and company announcements.

This topic contains 13 replies, has 3 voices, and was last updated by The Jackal The Jackal 3 days, 21 hours ago.

  • Creator
    Topic
  • #6185
    The Jackal
    The Jackal
    Participant

    Hi,

    I upgraded to the most recent 1.3 CE from 1.0 and ran platform:update runs without any errors. (my system ubuntu 16.04LTS, followed the upgrade instructios in https://www.orocrm.com/documentation/2.0/cookbook/how-to-upgrade-to-new-version)

    However, after unlocking from maintenance, the web page returns a blank page.

    Something is definitely went wrong. How do I see what went wrong? (the app/logs/prod.log shows no errors) or am I missing anything from the upgrade instructions?

    Thanks for any help or tips!

    Jackal

    • This topic was modified 1 week, 1 day ago by The Jackal The Jackal. Reason: additional information
Viewing 13 replies - 1 through 13 (of 13 total)
  • Author
    Replies
  • #6187
    The Jackal
    The Jackal
    Participant

    Update
    ——
    Managed to find the error in log/nginx/oroapp_error.log. It’s the cache permissions. It is working now.

    Thanks!

    #6192
    The Jackal
    The Jackal
    Participant

    Hi,

    When I went to the admin, system information…I still see the following:

    oro/redis-config 2.0.0-beta.1 MIT
    oro/doctrine-extensions 1.0.13 MIT
    oro/platform 2.0.0 MIT
    oro/marketing 2.0.0 OSL-3.0
    oro/crm-task-bundle 2.0.0 OSL-3.0
    oro/crm-call-bundle 2.0.0 OSL-3.0
    oro/calendar-bundle 2.0.0 OSL-3.0
    oro/crm 2.0.0 OSL-3.0
    oro/platform-serialised-fields 2.0.0 OSL-3.0
    oro/commerce 1.0.0 OSL-3.0
    oro/commerce-crm 1.0.0 OSL-3.0

    It still shows oro/commerce 1.0.0. Is that correct?

    #6199
    dnahrebecki
    dnahrebecki
    Oro Core

    hello @The Jackal,

    what is the output of

    ?

    Regards,
    Daniel Nahrebecki

    #6202
    The Jackal
    The Jackal
    Participant

    Hi Daniel,

    it shows:

    #6203
    iantypenko
    iantypenko
    Participant

    Hi @The Jackal.

    Which type of update are you using?
    “Checkout from the GitHub Repository” or “Download the Source Code Archive”

    Are you sure that you have downloaded newest version of orocommerce?

    #6204
    The Jackal
    The Jackal
    Participant

    Hi iantypenko,

    I checkout to a new branch that I created called branch1.3.0 from the tag 1.3. This is my git branch status below:

    fe73af8 is the same checksum as the original 1.3.0 tag in github.

    • This reply was modified 1 week, 1 day ago by The Jackal The Jackal.
    #6206
    iantypenko
    iantypenko
    Participant

    It looks like that packages were not updated.

    Next command should update packages.
    What the command returns?

    #6207
    The Jackal
    The Jackal
    Participant

    Hi iantypenok,

    Thank you! That’s the command that I have been missing!

    The admins should really consider updating the default orocrm update instructions for orocommerce.

    For everyone else, there are 2 instructions that are missing:

    Add the above 2 before the plaform:update command

    Thanks!!

    #6208
    The Jackal
    The Jackal
    Participant

    Hi,

    I tried to run oro:update and I encountered this error:

    How do I get past this error? Any help appreciated!

    #6209
    The Jackal
    The Jackal
    Participant

    I tried to clear cache again by running

    rm -rf app/cache/*
    rm -rf web/js/*
    rm -rf web/css/*

    It still failed at

    Any suggestions? At wits end.

    • This reply was modified 6 days, 17 hours ago by The Jackal The Jackal.
    #6212
    iantypenko
    iantypenko
    Participant

    We have instruction for oro commerce too:

    How to Upgrade to a New Version

    It has mentions about orocrm instead of orocommerce, but it will be fixed soon.

    According to “Killed” in your log I think your system kills process because system doesn’t have enough memory.

    #6214
    The Jackal
    The Jackal
    Participant

    Hi Iantypenko,

    That makes sense! I didn’t think about that. ok, will enlarge the memory and retry.

    I totally missed the orocommerce upgrade instructions. The blog should point to that instead of the usual orocrm.

    Many thanks again!

    #6226
    The Jackal
    The Jackal
    Participant

    Just an update … I ran with –timeout 0 and it ran successfully! Thanks Iantypenko!

Viewing 13 replies - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.