ssossossosso

Forums

Covering OroCommerce topics, B2B eCommerce trends, community updates and company announcements.

This topic contains 3 replies, has 2 voices, and was last updated by Michael Michael 1 year, 7 months ago.

  • Creator
    Topic
  • #963

    Hello Everyone,

    I am installing oro commerce through composer but when it is setting up some parameters it say something like that:

    Method Oro\Bundle\InstallerBundle\Composer\ScriptHandler::setAssetsVersion is not callable, can not call post-install-cmd script

    What is it?

    Is it an error?

    What is missing in my installation.

    Thank you

    > Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::buildBootstrap
    > Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::installRequirementsFile
    > Oro\Bundle\InstallerBundle\Composer\ScriptHandler::setPermissions
    > Oro\Bundle\InstallerBundle\Composer\ScriptHandler::installAssets
    Method Oro\Bundle\InstallerBundle\Composer\ScriptHandler::setAssetsVersion is not callable, can not call post-install-cmd script

    Additionally I provide to you the oro versions is installed on my server:

    [root@lo orocrm]# composer show –installed | grep oro
    oro/crm dev-master 0bae06b
    oro/doctrine-extensions 1.0.10
    oro/jsplumb 1.7.6
    oro/moment-timezone 0.3.1
    oro/platform dev-master 490a61d
    [root@lo orocrm]# php -i | grep memory_limit
    memory_limit => 1024M => 1024M

    Thank you!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Author
    Replies
  • #964
    Michael
    Michael
    Oro Core

    Hello Julio,

    It seems that you have installed OroCRM, not OroCommerce.

    If you are trying to add OroCommerce to an existing OroCRM installation then some additional care should be given to match the installed versions exactly. Both OroCRM and OroCommerce have dependency on OroPlatform and because of a more frequent OroCommerce Alpha versions publication cycle at this time it may utilize some OroPlatform features that have not yet been included in the last stable OroPlatform release.

    Thank you,
    Michael Bessolov

    #967

    Thank you Michael for your quick response!

    You are right! I am trying to install oro commerce following the manual online published on this webpage:

    http://www.orocrm.com/documentation/index/current/book/installation

    Can I continue installing on this way oro commerce?

    Which features do I have to consider in case that I want to install commerce Application?

    Thank you once more.

    Sincerely,

    Julio Vaca

    #968
    Michael
    Michael
    Oro Core

    This is a quick recap of how to install the latest Alpha release of orocommerce from https://github.com/orocommerce/orocommerce-application/blob/master/README.md :

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.