ssossossosso

Forums

Covering OroCommerce topics, B2B eCommerce trends, community updates and company announcements.

This topic contains 2 replies, has 2 voices, and was last updated by  avagarwal 9 months, 3 weeks ago.

  • Creator
    Topic
  • #2474

    avagarwal
    Participant

    Hi,

    I ame trying to install orocommerce under “wamp”. Composer install the various components and then asks for the relevant parameters. After that on trying to run web/install.php, I receive the following error message

    500 Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator at wampserver@wampserver.invalid to inform them of the time this error occurred, and the actions you performed just before this error.

    More information about this error may be available in the server error log.

    The apache error log show the following messsage

    [Fri Jan 20 19:24:39.051966 2017] [core:alert] [pid 6764:tid 900] [client 127.0.0.1:14218] D:/wamp64/www/web/.htaccess: Invalid command ‘Header’, perhaps misspelled or defined by a module not included in the server configuration

    The .htaccess file is

    What could be the issue?

    Thanks

    Anurag

Viewing 3 replies - 1 through 3 (of 3 total)
  • Author
    Replies
  • #2478

    filippo.delprete
    Participant

    Hi Anurag,
    Probably you have to enable the mod_headers module in Apache.
    Please check this in order to enable a module on Wamp.
    https://github.com/h5bp/server-configs-apache/wiki/How-to-enable-Apache-modules

    Filippo

    #2500

    avagarwal
    Participant

    Thanks. It solved the issue.

    Anurag

    #5326

    getvma
    Participant

    I have the same situation, however, I am unable to reach the site.

    I am using the following vhost settings;

    I have other development sites running on the same dev stack so I know that I am able to reach the web server successfully. Additionally, I was able to complete an orocommerce installation along with all of its migrations. I am also able to run the built-in php web server and access the website using 127.0.0.1:8000. I would prefer to run the site in wampserver instead.

    Here is the apache_error.log

    I am running wampserver 3.0.9 with PHP 7.1.6 & Apache 2.4.26 on Windows 10

    Any advice?

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.