ssossossosso

Forums

Covering OroCommerce topics, B2B eCommerce trends, community updates and company announcements.

This topic contains 11 replies, has 2 voices, and was last updated by  avinogradov 1 month, 3 weeks ago.

  • Creator
    Topic
  • #6181

    jorrit.vandenbroeck
    Participant

    Hi,

    I’m trying to generate a WSSE header from my API key using the command line interface.

    When I enter command:

    spg@SPG-ORO: php app/console oro:wsse:generate-header a077[rest of my api key]

    I get back this response:

    Could not open input file: app/console

    I’m running PHP 7.0.18 on Ubuntu 16.04.2. How can I get an WSSE Header?

    Any help is much appreciated. Jorrit

Viewing 11 replies - 1 through 11 (of 11 total)
  • Author
    Replies
  • #6182

    avinogradov
    Participant

    Hello,

    Can you please specify the folder where you execute the command?

    And also, please, provide the information concerning your environment as described in this topic:

    Please read this before starting a topic with technical question

    #6195

    jorrit.vandenbroeck
    Participant

    Hello Avinogradov,

    Here is my basic information:

    1. Application related information:

    Application Type: OroCommerce
    Application Version: 2.0.0-beta.1
    Application Edition: Community

    2. Environment related information:

    OS, name and version: Ubuntu 16.04.1
    Web server, name and version: Nginx 1.10.3
    Database, name and version: MySQL, 5.7.19

    PHP, version: 7.0.18

    I’ve tried running the command from the ROOT and BIN folders.

    Regards, Jorrit

    #6196

    avinogradov
    Participant

    “OroCommerce” recently published v1.3. When you say “2.0.0-beta.1” you probably mean “OroPlatform”. can you specify “OroCommerce” version you’re using?

    Basically, command line interface tells you that he does not see the file you’re trying to execute. That means, that you’re either not executing the command from an appropriate folder or the file does not exist for some reason.

    You should be executing this command from root of your project folder – this is where your src/ vendor/ web/ and more importantly app/ folders are. Make sure you’re executing command from an appropriate folder and then take a closer look at your “app/” folder – console.php file should be there. If it’s not, then try reinstalling the whole application or just see what happened to it using git history.

    #6197

    jorrit.vandenbroeck
    Participant

    Hello,

    Based on the package versions I see in the system information I assume it then is OroCommerce 1.1.1

    To be complete here is a screenshot of all ORO packages and their version info: https://ibb.co/ho6kZv

    Regarding running the command from the correct folder: I’m not familiar with the Linux platform was just able to install ORO using a step-by step manual. I do not know which folder contains the project but I think it’s safe to assume it will be the default folder.

    What would be the default ORO project folder (+ path)?

    Thanks, Jorrit

    #6198

    avinogradov
    Participant

    Could you post a link to the manual you used?

    #6200

    jorrit.vandenbroeck
    Participant

    Hello,

    The used installation manual is:

    https://github.com/orocommerce/orocommerce-application

    After the installation was completed a few months ago Somebody has been “working” on the server to get integration going. He finally couldn’t get it working but I do not know what he’s been changing in the meanwhile.

    Is there an easy way to check if the required folders and/or content even still exist? (fyi, the front-end website works perfectly fine)

    Regards, Jorrit

    #6201

    avinogradov
    Participant

    First, you have to understand where the root of your project is. You said that you’re using Nginx. There are nginx configuration files on your linux that tell the server that requesting some domain should execute index.php(for example) in some folder on your machine (the root folder configuration). I cannot know what folder it is exactly, because they are configured customly. There are many manuals as to how to find out where your projects roots are on the internet. This one fox example – http://nginx.org/en/docs/http/request_processing.html

    Most commonly, your nginx configuration files would be in /etc/nginx/nginx.conf, there you must look for the domain you’re opening in your browser and look for “root” configuration – there you will find where your project root and THAT is where you need to execute the command.

    #6287

    jorrit.vandenbroeck
    Participant

    Hello,

    After week of vacation I’m picking this back up. First of all thanks for helping me so far.

    I found the NGINX.CONF file. In this file nowhere do I see reference to a “root” configuration. See content of the file below.

    Where in the fiel do I see reference to my root folder?

    Thanks.

    Content of /etc.nginx/nginx.conf:

    spg@SPG-ORO:/$ vim /etc/nginx/nginx.conf
    ##
    # SSL Settings
    ##

    ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE
    ssl_prefer_server_ciphers on;

    ##
    # Logging Settings
    ##

    access_log /var/log/nginx/access.log;
    error_log /var/log/nginx/error.log;

    ##
    # Gzip Settings
    ##

    gzip on;
    gzip_disable “msie6”;

    # gzip_vary on;
    # gzip_proxied any;
    # gzip_comp_level 6;
    # gzip_buffers 16 8k;
    # gzip_http_version 1.1;
    # gzip_types text/plain text/css application/json application/javascript text/xml application/xml application/xml+rss text/javascript;

    ##
    # Virtual Host Configs
    ##

    include /etc/nginx/conf.d/*.conf;
    include /etc/nginx/sites-enabled/*;
    }

    #mail {
    # # See sample authentication script at:
    # # http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript
    #
    # # auth_http localhost/auth.php;
    # # pop3_capabilities “TOP” “USER”;
    # # imap_capabilities “IMAP4rev1” “UIDPLUS”;
    #
    # server {
    # listen localhost:110;
    # protocol pop3;
    # proxy on;
    # }
    #
    # server {
    # listen localhost:143;
    # protocol imap;
    # proxy on;
    # }
    #}

    #6288

    avinogradov
    Participant

    ##
    # Virtual Host Configs
    ##
    include /etc/nginx/conf.d/*.conf;
    include /etc/nginx/sites-enabled/*;
    }

    See those folders for configurations. You should see the domain name you’re trying to reach in the name of one of configuration files(most commonly).

    #6314

    jorrit.vandenbroeck
    Participant

    Great. I found the domain name in the file you pointed me to.

    Using sudo -s I am able to navigate to the folder in which app/console is located.

    I now can succesfully generate the SSWE Header.

    Thanks a lot.

    Regards, Jorrit

    #6315

    avinogradov
    Participant

    Glad to be of assistance.

Viewing 11 replies - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.