ssossossosso

Forums

Covering OroCommerce topics, B2B eCommerce trends, community updates and company announcements.

OroCommerce, an open-source B2B commerce platform. Forums OroCommerce Issue installing compser during OroCommerce installation

This topic contains 2 replies, has 2 voices, and was last updated by ypetrov ypetrov 5 months ago.

  • Creator
    Topic
  • #2097
    artelcreative
    artelcreative
    Participant

    As a pre-cursor to my issue, I have very little SSH or comandline experience so may possibly be making a glaring mistake but don’t realise it..

    I’m trying to install OroCommerce on my shared cloud hosting and have been following the instructions within the readme file included wth the application files but when it comes to installing composer I get the following error:

    Warning: Composer should be invoked via the CLI version of PHP, not the cgi-fcgi SAPI
    Composer could not find a composer.json file in /var/sites/mydomain.com
    To initialize a project, please create a composer.json file as described in the https://getcomposer.org/ “Getting Started” section

    Firstly the warning regarding CLI… I’ve found information suggesting that the use of php -cli composer.phar install will resolve this but it makes no difference and the error message is the same.

    I’ve read through the composer guide on creating a composer.json file but as the file exists in the orocommerce-application folder I’m not sure that creating one is the issue here, perhaps more that I’ve done something wrong preventing composer from accessing the file?

    I’ve tried moving the composer.json file from it’s folder into the domain’s root and whilst that does start installation I then get the following error:

    Warning: Composer should be invoked via the CLI version of PHP, not the cgi-fcgi SAPI
    Loading composer repositories with package information
    Updating dependencies (including require-dev)
    <br />
    <b>Fatal error</b>: Maximum execution time of 30 seconds exceeded in <b>phar:///var/sites/mydomain.com/composer.phar/src/Composer/Package/Package.php</b> on line <b>109</b><br />

    Any help would be greatly appreciated.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Author
    Replies
  • #2098
    ypetrov
    ypetrov
    Participant

    Hello, you shouldn’t move composer.json file to another folder, just run composer install from this folder.
    Seems like /var/sites/mydomain.com should contains file from OroCommerce but not folder the “orocommerce-application”.
    To avoid error “Maximum execution time of 30 seconds exceeded” you can try to increase this limit, take a look at /etc/php/…/php.ini parameter

    #2131
    ypetrov
    ypetrov
    Participant

    I hope, you’ve solved this issue, if not feel free to reopen the topic

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.