ssossossosso

Forums

Covering OroCommerce topics, B2B eCommerce trends, community updates and company announcements.

This topic contains 3 replies, has 2 voices, and was last updated by  t.engelke 3 months, 2 weeks ago.

  • Creator
    Topic
  • #2755

    t.engelke
    Participant

    I’ve set up a new virtual box with Debian Jessie, MySQL and Apache, with all the required software installed. Going through the motions of the README.md, I come across this problem:

    root@j306885:/var/www/html/orocommerce-application# /usr/bin/php5 app/console oro:organization:update default –organization-name=Ourname –env=prod

    [Doctrine\ORM\NoResultException]
    No result was found for query although at least one row was expected.

    oro:organization:update [–organization-name [ORGANIZATION-NAME]] [–organization-description [ORGANIZATION-DESCRIPTION]] [–organization-enabled [ORGANIZATION-ENABLED]] [-h|–help] [-q|–quiet] [-v|vv|vvv|–verbose] [-V|–version] [–ansi] [–no-ansi] [-n|–no-interaction] [-s|–shell] [–process-isolation] [-e|–env ENV] [–no-debug] [–disabled-listeners DISABLED-LISTENERS] [–] <command> <organization-name>

    In app/logs there’s only a prod.log file, containing this:

    [2017-02-03 08:52:21] console.ERROR: An error occurred while running command “‘oro:organization:update’ default –organization-name=Ourname –env=prod”. No result was found for query although at least one row was expected. {“exit_code”:0,”arguments”:{“command”:”oro:organization:update”,”organization-name”:”default”},”options”:{“organization-name”:”Ourname”,”env”:”prod”}} []

Viewing 4 replies - 1 through 4 (of 4 total)
  • Author
    Replies
  • #2792
    Michael
    Michael
    Oro Core

    It looks like one of the previous installation attempts failed and now the application is being installed on an inconsistent database.

    Please clean the cache, drop and re-create the database, change “installed” parameter in app/config/parameters.yml to false, and restart the installation again.

    #2805

    t.engelke
    Participant

    Alright. These are the steps I have taken:

    1. Drop the schema

    drop schema b2b_dev;

    2. Recreate the schema

    create schema b2b_dev;

    3. Clear the cache

    php app/console cache:clear –env prod

    The result:

    // Clearing the cache for the prod environment with debug false

    [Doctrine\DBAL\Exception\InvalidFieldNameException]
    An exception occurred while executing ‘SELECT o0_.serialized_data AS serialized_data_0, o0_.id AS id_1, o0_.name AS name_2, o0_.language_code AS language_code_3, o0_.formatting_code AS formatting_code_4, o0_.created_at AS created_at
    _5, o0_.updated_at AS updated_at_6, o1_.serialized_data AS serialized_data_7, o1_.id AS id_8, o1_.name AS name_9, o1_.language_code AS language_code_10, o1_.formatting_code AS formatting_code_11, o1_.created_at AS created_at_12, o1_
    .updated_at AS updated_at_13, o0_.parent_id AS parent_id_14, o1_.parent_id AS parent_id_15 FROM oro_localization o0_ LEFT JOIN oro_localization o1_ ON o0_.id = o1_.parent_id’:
    SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘o0_.serialized_data’ in ‘field list’

    [Doctrine\DBAL\Driver\PDOException]
    SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘o0_.serialized_data’ in ‘field list’

    [PDOException]
    SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘o0_.serialized_data’ in ‘field list’

    cache:clear [–no-warmup] [–no-optional-warmers] [-h|–help] [-q|–quiet] [-v|vv|vvv|–verbose] [-V|–version] [–ansi] [–no-ansi] [-n|–no-interaction] [-s|–shell] [–process-isolation] [-e|–env ENV] [–no-debug] [–disabled-listeners DISABLED-LISTENERS] [–] <command>

    #2963

    t.engelke
    Participant

    After restarting the installation process from the top (cloning), I could successfully install and run the application.

    #2806

    Alex Puscas
    Participant

    Hello Engelke!

    There seams to be a problem with the cache. It might be generated from the database you had before. Try removing it before installing the application or clearing the cache.

    Also, please try running composer install first, if you didn’t do it already.

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.