ssossossosso

Forums

Covering OroCommerce topics, B2B eCommerce trends, community updates and company announcements.

This topic contains 13 replies, has 3 voices, and was last updated by  mmiasnikov 2 months, 3 weeks ago.

  • Creator
    Topic
  • #5555

    Dima Makaruk
    Participant

    How to add product attribute programmatically in a Migration and assign it to an Attribute Family and Group?

Viewing 13 replies - 1 through 13 (of 13 total)
  • Author
    Replies
  • #5559
    msulima
    msulima
    Oro Core

    Hello, Dima Makaruk.

    Adding new data attribute requires schema update. So, it may take long time.

    At first, you should add extended field to entity. Let it be enum field.

    Next code in fact makes attribute from enum field.

    Also, please, see example of adding attribute here: LoadDefaultAttributesData
    Example, of creation family and group: LoadProductDefaultAttributeFamilyData

    #5560

    Dima Makaruk
    Participant

    Hi msulima,

    thank you for the info.

    I have already added one enum field in Entity Management , after that i’m getting an error:

    Looks like a problem in filter.

    The field config looks as follows:

    #5561
    msulima
    msulima
    Oro Core

    Which migration did you use?

    #5566

    Dima Makaruk
    Participant

    I’ve added the field in backend in Entity management

    #5567
    msulima
    msulima
    Oro Core

    Hm, maybe it is an issue. But still please try code from links that I poster above.
    And, please steps to reproduce issue with enum field.

    #5568

    Dima Makaruk
    Participant

    In System > Entities > Entity manager i’ve found the Product entity in grid and added a multiselect field with 2 options. After that the column for the field was added in the oro_product table and the config was created for the field. The table for enum values also exists.

    Now it is also not possible to edit this field in the Entity manager:

    #5571
    msulima
    msulima
    Oro Core

    Please, give me version of your application. I’ll try to reproduce that bug.
    Also please tell, did you click Update schema button?

    #5573

    Dima Makaruk
    Participant
    #5574
    msulima
    msulima
    Oro Core

    Oh, this version currently not supported anymore. Please, update version of your application.

    #5586

    Dima Makaruk
    Participant

    Hi

    I’ve tried to update to 1.3

    https://github.com/orocrm/commerce-crm-enterprise.git was not found.

    #5587

    Dima Makaruk
    Participant

    In the master branch of the application this dependency “oro/commerce-crm-ee”: “1.3.*” is not there any more and i could install all the dependencies.

    How is it possible to install the 1.3 version of the app ?

    #5603

    Dima Makaruk
    Participant

    Which stable version of the application ‘orocommerce-enterprise-application’ should i use for the update ?

    #5624

    mmiasnikov
    Oro Core

    Hi, Dima.

    As an Enterprise edition user, you should direct you questions to dedicated Enterprise support site and team: http://support.orocommerce.com.

    Sincerely

Viewing 13 replies - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.