ssossossosso

Forums

Covering OroCommerce topics, B2B eCommerce trends, community updates and company announcements.

This topic contains 9 replies, has 3 voices, and was last updated by  zboldizsar 1 week, 1 day ago.

  • Creator
    Topic
  • #7024

    alexvoronkrd
    Participant

    Trying to install oro commerce but there is not clear error. The server was configured according to the instructions running on apache2. The maximum far is to check the server then goes to error 500. The logs of apache2 is attached.
    Access denied for user ‘root’@’localhost’ (using password: NO) in /public_html/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:43\nStack trace:\n#0 /public_html/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php(43): PDO->__construct(‘mysql:host=127….’, ‘root’, NULL, Array)\n#1 /public_html/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOMySql/Driver.php(44): Doctrine\\DBAL\\Driver\\PDOConnection->__construct(‘mysql:host=127….’, ‘root’, NULL, Array)\n#2 /public_html/vendor/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(360): Doctrine\\DBAL\\Driver\\PDOMySql\\Driver->connect(Array, ‘root’, NULL, Array)\n#3 /public_html/vendor/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(429): Doctrine\\DBAL\\Connection->connect()\n#4 /public_html/vendor/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(389): Doctrine\\DBAL\\Connec in /public_html/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/AbstractMySQLDriver.php on line 103, referer: http://******/install.php

    ————— – – [13/Sep/2017:03:47:54 -0400] “GET /installer HTTP/1.1” 500 185 “http://********/install.php” “Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.9 Safari/537.36”

Viewing 9 replies - 1 through 9 (of 9 total)
  • Author
    Replies
  • #7029
    msulima
    msulima
    Oro Core

    Hi,

    probably you should set database password for ‘root’ user in ‘parameters.yml’.

    #7035

    alexvoronkrd
    Participant

    Good afternoon. Even changes to the settings.yml (parameters:
    database_driver: pdo_mysql
    database_host: localhost
    database_port: 3306
    db_name: xukxam
    database_user: sedmax
    database_password: Ghjvbcrebntn1 has not remedied the situation. the apache2 log file says the following:
    [Thu Sep 14 03:17:36.629909 2017] [:error] [pid 576] [client *************] PHP Fatal error: Uncaught PDOException: SQLSTATE[HY000] [1049] Unknown database ‘b2b_crm_dev’ in /vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:43\nStack trace:\n#0 /vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php(43): PDO->__construct(‘mysql:host=127….’, ‘root’, ‘Ghjvbcrebntn1’, Array)\n#1 /vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOMySql/Driver.php(44): Doctrine\\DBAL\\Driver\\PDOConnection->__construct(‘mysql:host=127….’, ‘root’, ‘Ghjvbcrebntn1’, Array)\n#2 /vendor/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(360): Doctrine\\DBAL\\Driver\\PDOMySql\\Driver->connect(Array, ‘root’, ‘Ghjvbcrebntn1’, Array)\n#3 /vendor/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(429): Doctrine\\DBAL\\Connection->connect()\n#4 /vendor/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(389): Doctrine\\DBAL\\Connection->getDatabasePlatformVersion()\n#5 /var/www/web/xukxam.xyz/vendor/do in /vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/AbstractMySQLDriver.php on line 103

    #7047

    zboldizsar
    Participant

    Hi,

    I see you have a ‘db_name’ parameter in you parameters.yml, is that a mistake, or it’s a custom parameter? The correct name is ‘database_name’. Please delete your cache after modifying the file, and make sure you have the database created with name defined in ‘database_name’.

    #7050

    alexvoronkrd
    Participant

    All entered parameters are correct. While OROCRM installed without a problem. But ORO Commerce (during the transition to install.php no error indicates but trying to move on to the next step reports /orocommerce-application/web/installer was not found

    #7053

    zboldizsar
    Participant

    Can you please try to use the terminal installer (following this), and post back the whole results the installer gives you? Thank you!

    #7054

    alexvoronkrd
    Participant

    Tried to install via the console terminal. All over no luck on the command composer install –prefer-dist he gave kiled and that’s all okonchilos

    #7055

    zboldizsar
    Participant

    Can you give me a screenshot/detailed contents of the composer failed command?

    #7056

    alexvoronkrd
    Participant

    doing the installation from the console enter the command: git clone https://github.com/orocommerce/orocommerce-application.git downloads the files everything goes well – then run the command composer install –prefer-dist in the terminal leaves a message (loading composer repositories with package information. Updating dependencies (including require-dev)) after a while getting Killed in what a problem of mind is not preloge.

    #7057

    zboldizsar
    Participant

    Do you have xdebug enabled?

Viewing 9 replies - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.